Cookie consent

AstroBin saves small pieces of text information (cookies) on your device in order to deliver better content and for statistical purposes. You can disable the usage of cookies by changing the settings of your browser. By browsing AstroBin without changing the browser settings, you grant us permission to store that information on your device.

I agree

QHY PoleMaster Issues

01 Dec, 2019 09:37
I've been working with QHY to troubleshoot this.
Well done Jon, he needs to be aware that several are having these problems.  He's sorted fixes for things in the past so hopefully will again.

I used Polemaster on Friday night and it worked perfectly I am pleased to say and hopefully won't need to use it again until the spring as it's in my home observatory, then I'll be back to astro trips to campsites and using it every month.

05 Dec, 2019 19:35
My Polemaster has worked with zero issues for over a year now.  However I did have similar issues with my ASI1600mm.  I had to connect the camera by itself with the 6 foot supplied cable all by itself to a separate USB port on the laptop.  I ended up using a short USB cable to a new Powered USB 3 hub and all now works well.  USB can be a PITA to figure out.  Good Luck

05 Dec, 2019 21:02
I had this issue and this is how I resolved it…It is a Windows issue.
CS and Keep looking up!
Edited 09 Dec, 2019 17:32
05 Dec, 2019 21:03
I had this issue and this is how I resolved it…It is a Windows issue.
CS and Keep looking up!
Edited 09 Dec, 2019 17:31
05 Dec, 2019 21:04
Edited 05 Dec, 2019 21:05
05 Dec, 2019 22:10
Kudos to you Rich Sky! This looks like a good fix! Nicely done. I disabled the power setting via device manager for all USB devices to no avail. Your method, however, seems to work! THANK YOU!

11 Dec, 2019 02:45
I had a few hours tonight to conduct some experiments with my PoleMaster camera, and I'd like to share the results.

The PoleMaster software seems a bit buggy, and would get messed up every now and then causing plenty of confusion - so be wary of that. When I started having *unusual* problems (i.e. more than just the stuttering), it seemed to mostly be due to the buggy software, so shutting down the software, disconnecting the camera, then starting all over again would almost always fix those types of issues. This does NOT fix the stuttering and freezing issue.

When I had the PoleMaster connected directly to my laptop, and the laptop was plugged into an electrical outlet, the camera never failed. When I had the laptop disconnected from the electrical outlet, the camera usually failed, often stuttering a little before "freezing". By "freeze", I actually mean that images would only get refreshed once or twice at random intervals anywhere from 5 to 20 seconds. Sometimes the camera would spontaneous start working fine again for a short period of time before freezing again, but there was no way I would rely on it long enough to complete a polar alignment. When the stuttering or freezing occurred, plugging the laptop back into an electrical outlet always fixed the problem immediately. The reverse was also true… if the camera was working perfectly and then I disconnected the laptop from the electrical outlet, the camera would usually stutter to a freeze very quickly. With these results alone, this seems like this issue is a power problem.

Going into Device Manager, there is a Universal Serial Bus controllers section that contains the USB driver information and controls. Opening the properties of the items reveals that some of them have a Power Management tab containing an option box to "Allow the computer to turn off this device to save power". Un-checking these boxes didn't seem to have any impact on this issue at all.

Next, I connected my Pegasus Astro Ultimate Powerbox v2 to my laptop via USB and powered the Powerbox with my Celestron PowerTank Lithium Pro. Then I connected the PoleMaster to one of the Powerox's powered USB 3.1 ports. Again, as long as the laptop was plugged into an electrical outlet, the camera worked flawlessly, but as soon as I unplugged the laptop from the electrical outlet, the stuttering would start. This is exactly the same behavior I got when I had the camera plugged directly into the laptop's USB port. The Powerbox made absolutely no difference whatsoever. I do not understand this at all! The Powerbox should be powering the camera using power from the PowerTank, not from the laptop, right? Maybe I'm wrong about this, but I don't think so because providing power is what the Powerbox is all about. So then, why would the laptop's power source affect the camera attached to the Powerbox? This is now starting to seem more like a data problem than a power problem. Does the USB hardware (or drivers) of certain laptaps (including mine) have a problem transmitting and/or receiving data when receiving power from a battery instead of an electrical outlet?

In conclusion, it seems I have found a way to guarantee that the PoleMaster will work: make sure the laptop is plugged into an electrical outlet. This is not the solution I was hoping for because I also want to be able to set up at dark sites that don't have electrical outlets. I don't know what other testing I could do to try to figure this out - I just don't know enough about how USB ports work (or don't work) to progress any further.

Jon… if you are still communicating with QHYCCD about this issue, maybe you could share my results with them in the hopes it might help?
11 Dec, 2019 03:13
I tried disabling the "Allow the computer to turn off this device to save power" setting also to no avail. However, have you tried the following?

Settings>>Power & Sleep>>Additional Power Settings>>Change Plan Settings>>Change Advanced Power Settings>>USB Settings>>USB selective suspend setting>>On Battery & Plugged In both set to disabled

11 Dec, 2019 10:19
I always used polemaster on a laptop that is not plugged into charger , never had a problem of any sort , must be a power issue with your laptop as with the other user issues? Software cant be buggy as it would be so to me?
Edited 11 Dec, 2019 10:19
11 Dec, 2019 23:46
Jon - I really want to try your suggestion, but I cannot. For some reason, my Dell Inspiron 15 7000 2-in-1 does not have the "USB Settings" available in the advanced settings. It only has:

  • Desktop background settings
  • Sleep
  • Power buttons and lid
  • Display
  • Battery
It's not nested under any of those either. Any ideas why I might not have that option, or an alternative location I could look for it? If I type "USB" in the search box on the  main settings screen, I find a checkbox for "Stop devices when my screen is off to help save battery. If you're having problems with connected devices, clear the checkbox." I tried clearing this option and it didn't make a difference either.

I've also looked through the BIOS to see if I could find anything. I found an option to "Enable USB Wake Support", which in itself is not helpful here. However, it specifically says: "This feature is only functional when the AC power adapter is connected. If the AC power adapter is removed before Standby, the BIOS will remove power from all of the USB ports to conserve battery power." I suspect my computer is just set up to remove power from the USB when the AC power is removed, no matter what. But that still doesn't explain why the problem persists when I power the camera with the Pegasus Astro Ultimate Powerbox v2, unless the powerbox isn't actually powering it like it says it is.

apophis - The software runs pretty well as long as you don't have to deal with the stuttering problem. If I have to disconnect and shut down multiple times, like I did during my testing, the software itself would sometimes freeze and crash. Not a big deal, just something to be aware of when troubleshooting. And for the record, pretty much all software is buggy. And I have to agree it still seems like a power issue, yet when powering the camera with a different power source (my powerbox in this case), the issue continues to depend on whether or not the laptop is plugged in. It makes no sense to me.
Edited 12 Dec, 2019 04:54
12 Dec, 2019 01:03
This is for Windows 10. Maybe Try this:

From the Desktop, right click and choose "Display Settings".

Then, Power & Sleep>>Additional Power Settings>>(Depending which plan you're using "Balanced" or "Power Saver" option)Change Plan Settings>>Change Advanced Power
Settings>>(A dialog box should open with an "Advanced Settings" tab. In the dropdown box, choose your current plan setting.) Then scroll down to USB Settings>>USB selective suspend
setting>>On Battery & Plugged In both set to disabled

12 Dec, 2019 05:47
It turns out that some laptops (including mine) have the USB Settings missing under the advanced power settings. To restore the option I followed the instructions at this link. Once I had the USB Settings restored, I disabled the selective suspend for both the battery and plugged in. Then I unplugged the laptap… and the camera kept working… for about 15 seconds. smile This option DOES have a positive effect, but the effect doesn't last long enough to be useful for me.

I've written to Pegasus Astro to ask if they have any idea why the problem seems to pass through their Powerbox v2.
13 Dec, 2019 16:16
Usb power solution
Edited 13 Dec, 2019 16:17
13 Dec, 2019 17:38
Received the updated app from QHY today with the added USB traffic controls but, alas, it does not work. Also, the selective USB suspend fix mentioned above has stopped working for me. I have informed QHY and await their reply. I did reiterate that there were many others experiencing the same issue.
I have had good luck with using the Polemaster camera with Sharpcap and the USB traffic setting of 255. One anomaly there was that I have to slide the USB slider to zero and then back to 255 (i.e. cannot start at 255) in order for it to work.

13 Dec, 2019 21:22
This same thing always happens on my Mac and never with my pos Windows machine–same cable. Sure seems like it's their app.
14 Dec, 2019 19:51
As a workaround for those with laptops that have integrated cameras, maybe try this:
 (You will need a version of SharpCap installed.)

 Don't plug Polemaster camera to USB yet.
 Before launching Polemaster, launch SharpCap and connect to your laptops integrated camera until you see video from your camera.
 Minimize SharpCap.(Don't close it!)
 Connect Polemaster to USB and start as usual.

I let QHY know that the latest update didn't fix the problem. Since it's the weekend, I haven't heard a reply yet. I will let them know about this workaround as well.

Edited 14 Dec, 2019 19:59
15 Dec, 2019 01:57
I've had no problems with Polemaster and a HP intel i3 Windows 10.  I go from the Polemaster to a powered USB 3.0 Hub and to the laptop.  For some reason Polemaster does not like it when I use a bluetooth mouse.  The picture will keep jumping back to center when I try to drag it.  So I just use a wired mouse, plus that  is 1 less battery that can die on me.
Edited 15 Dec, 2019 04:30
17 Dec, 2019 12:57
Just my solution for Dell XPS 15 9570

Start with Bios-Setup (F2)
- deactivate C-States Control
- activate USB PowerShare

After a lot of other comments (play video, active hubs …smile this works now perfect for me.  Connected directly on USB-Ports and also with passive hubs. Active hub ist not necessary.
Maybe it helps.
Register or login to create to post a reply.